Pricing Service Performance Slowdown

Incident Report for Bitwave

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 05:58 PDT

Monitoring

We believe this has been fixed, we're monitoring now
Posted Jul 03, 2025 - 13:22 PDT

Investigating

Our engineering team has observed some performance issues with our pricing service. This may lead to longer than expected run times in reporting as well as some timed out reports. The team is triaging the issue and will provide a more detailed update shortly
Posted Jul 03, 2025 - 13:03 PDT
This incident affected: Pricing.