Bitwave Performance & Speed
Incident Report for Bitwave
Resolved
This incident has been resolved.
Posted Apr 07, 2023 - 12:00 PDT
Investigating
Dear valued clients,

We are aware that our application is loading slowly, and we understand that this is impacting your user experience. We want to assure you that our technical team is actively working on a solution to improve the performance of our application.

We have identified the root cause of the issue and are implementing fixes today and over the next several days to make Bitwave load faster. We estimate that the improvements will be visible within the next 3-5 business days.

We apologize for any inconvenience this may have caused and appreciate your patience as we work to resolve this issue.

Thank you for your understanding. If you have any questions or concerns, please don't hesitate to reach out to our customer support team at support@bitwave.io.

Sincerely,
The Bitwave Team.
Posted Mar 30, 2023 - 12:41 PDT
This incident affected: Bitwave App.