Balance Reports may show Stale Data

Incident Report for Bitwave

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 20:10 PST

Investigating

We are currently investigating this issue.
Posted Jan 29, 2026 - 07:25 PST
This incident affected: Bitwave Core.