GCP Outage Impacting Platform Availability

Incident Report for Bitwave

Resolved

Google has resolved the issue
Posted Jun 12, 2025 - 20:58 PDT

Update

We are continuing to monitor for updates.
Posted Jun 12, 2025 - 11:21 PDT

Identified

We’re currently experiencing service disruptions due to Google Cloud Platform (GCP) outage impacting key infrastructure. Core services may be intermittently unavailable. More updates to follow.
Posted Jun 12, 2025 - 11:20 PDT
This incident affected: Bitwave App.