Bitgo Connection
Incident Report for Bitwave
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 16:13 PST
Update
Our engineers are working diligently to complete the maintenance upgrade very shortly.
Posted Feb 01, 2023 - 08:14 PST
Update
We have identified the source of the issue and our engineers are working to resolve this.
Should you experience any issues with your connection during this period please contact us at support@bitwave.io.
Posted Dec 21, 2022 - 23:29 PST
Identified
We are currently servicing our Bitgo Connection for enhanced performance for our users.

Should you experience any issues with your connection during this period please contact us at support@bitwave.io.
Posted Dec 21, 2022 - 23:27 PST
This incident affected: Exchange Syncers (BitGo).