Updating Transactions May Be Delayed

Incident Report for Bitwave

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 19:54 PST

Investigating

We are currently investigating this issue.
Posted Jan 26, 2026 - 08:46 PST
This incident affected: Bitwave Core.