Intermittent Display Issue with Transaction Actions

Incident Report for Bitwave

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 11:03 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 18:24 PDT

Investigating

Some users may experience display issues when performing actions on transactions, such as categorization. In some cases, recently updated transactions may not immediately reflect their most current status. Our team is actively investigating the issue and working to implement a prompt resolution.
Posted Jul 17, 2025 - 10:31 PDT
This incident affected: Bitwave Core.